For twake server not start

anyone know how this issue is solve

If this is not working after 5 minutes, please restart all the docker with docker-compose stop;docker-compose up -d
We are trying to improve this process in the future!

Okay no problem
thanks for give me reply

it’s the same not started I try after 20 min but it still gives me the same error

Is the message still about “waiting DB to start” ?
There is 6 steps in the initialisation:

  • 1/4 Starting PHP
  • 2/4 Waiting to connect to ScyllaDB
  • 2/4 Initialising tables in scylladb
  • 3/4 Waiting for connection to ElasticSearch
  • 3/4 Initialising mapping into ElasticSearch
  • 4/4 Installing default data and connectors

In your first image, it seems to be stuck with ScyllaDB, you can see what is happening to ScyllaDB with:
docker-compose logs -f --tail 100 scylladb

Then for the table initialisation it can hang during the initialisation so the easy way is to do:
docker-compose stop;docker-compose up -d

For the ElasticSearch part, you need to increase this (in the host machine, not in docker):
sysctl -w vm.max_map_count=262144
You also need to run this command:
chmod 777 ./docker-data/es-twake
To follow what elasticsearch is doing:
docker-compose logs -f --tail 100 elasticsearch

If you cannot find a way to start elasticsearch, you can disable it and run Twake without search, follow https://doc.twake.app/configuration to edit your configuration and set "es" => false

Then the last parts should go without issues.
You can follow the main logs to have an overview here:
docker-compose logs -f --tail 100 php

Hope it helps, for each step, you can share your logs for me to help you.

docker-compose logs -f --tail 100 scylladb
after this command run it give me this type of log

scylladb_1 | Scylla requires the sse4.2 and clmul instruction sets, check your processor and hypervisor
scylladb_1 | Scylla requires a processor with SSE 4.2 and PCLMUL support
scylladb_1 | 2020-11-02 05:10:07,226 INFO exited: scylla (exit status 71; not expected)
scylladb_1 | 2020-11-02 05:10:08,316 INFO spawned: ‘scylla’ with pid 210
scylladb_1 | 2020-11-02 05:10:09,354 INFO success: scylla entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
scylladb_1 | Scylla requires the sse4.2 and clmul instruction sets, check your processor and hypervisor
scylladb_1 | Scylla requires a processor with SSE 4.2 and PCLMUL support
scylladb_1 | 2020-11-02 05:10:12,595 INFO exited: scylla (exit status 71; not expected)
scylladb_1 | 2020-11-02 05:10:13,751 INFO spawned: ‘scylla’ with pid 219
scylladb_1 | 2020-11-02 05:10:14,887 INFO success: scylla entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
scylladb_1 | Scylla requires the sse4.2 and clmul instruction sets, check your processor and hypervisor
scylladb_1 | Scylla requires a processor with SSE 4.2 and PCLMUL support
scylladb_1 | 2020-11-02 05:10:17,798 INFO exited: scylla (exit status 71; not expected)

hello @Jenis I ran into a similar problem when installing Twake inside a proxmox KVM virtual machine.
You can find the issue and my solution on Twake’s GitHub here: https://github.com/TwakeApp/Twake/issues/98#issuecomment-688910430
Perhaps this helps.