Selfhosted Jitsi Meet

Hello, I have a selfhosted instance of Twake and it’s working quite well.

I have also a selfhosted instance of Jitsi.

I have two problems:

(1) Eventhough I add the Jitsi App to the Workspace, Jitsi does not appear on the list of applications.
(2) By chance I discover that on the botton of the window chat (where the users write the new messages), there is one hidden icon between the smile icon and the Send button that opens one meeting request request. If I click on it, it opens Jitsi, but the public instance.

I wonder if it is possible to setup my selfhosted instance of Jitsi Meet to work with Twake. I guess that I should edit the file “configuration/backend/Parameters.php”, but I don’t know what parameters should I add inside “connectors”

Thank you in advance.

Hi, thanks for using Twake.
You spotted a bug with the Jitsi icon which should not be transparent / invisible. We’ll fix this soon (our team is in holiday)
To edit Jitsi configuration, you must follow this documentation:

https://github.com/TwakeApp/Twake/blob/main/documentation/connectors/jitsi.md

Thank you for your response. I followed the link with the documentation but unfortunately Twake seems that don’t want to use my selfhosted instance of jitsi. I wrote the following code:

        //Defaults values for all clients but editable in database
        "defaults" => [
          "applications" => [
            "twake_drive" => [ "default" => true ], //False to not install
            "twake_calendar" => [ "default" => true ],
            "twake_tasks" => [ "default" => true ],
            "connectors" => [
                    "jitsi" => [  "default" => true ],
            ]
          ],
          "connectors" => [
                  'jisti' => [
                            'jitsi_domain' => '{jitsi_ip}'
                    ]
          ],

where {jitsi_ip} is the internal IP where jitsi is listening to. But when I try to create a meeting, Twake alwais use the public instance of jitsi, not mine.

Nothing changes if I move ‘jitsi_domain’ upper in the config or if I put “default” to false.

We wrote “jisti” instead of “jitsi” in our documentation, I think the error come from this type, can you try with the correct spelling?

Hello, thanks for the tip. Now it’s working :slightly_smiling_face:. I followed the documentation and I didn’t see the bad spelling. After the fix it works using a public instance, but if I use one jitsi instance with one self-signed certificate, only a blank page is showed.

Is it possible to override the checking of a self-signed certificate?

Thank you very much for your support.

We don’t check the certificate, but as we use the Jitsi API from Twake, you need to enable HTTPS in Twake and in Jitsi. You cannot mix HTTP and HTTPS.

Here is what happen when you join a Jitsi call:

  1. A special Twake url is opened in browser, so the Jitsi page is displayed from Twake server
  2. This page load an external script from Jitsi API at https://meet.jit.si/external_api.js (or https://my.jitsi.server/external_api.js)
  3. We use this API to start a call full screen.

If this is not due to HTTP mixed with HTTPS, try to look at the console in your browser, in the network section, search what happen when loading the external_api.js file.

Good luck, Romaric

Thank you very much for you support.

Now it’s working.